Search Engine Friendly URLs NGINX

Hi there.

I'm setting up the script on my Debian 10 Nginx server and the option for search engin friendly urls in admin cp/options does not work on my NGINX server. Can someone share what code I need to put in my configuration file to correct this problem?

The default setting has urls with strings like which shows an individual cards. However,  when I change to Search Engine Friendly Urls at Admin CP/options/ and change the Search Engine Friendly Urls to yes I get an error 404 at the new URL at