Community Forum

Please read the intro before joining/posting. Thank you.

If you have questions about our software, chances are this forum has the answers.

You'll need to register before you can post on the forum to ask your question or to answer another one. A reply will be posted to each and every question that is asked so there is no need to double post or bump your post. We'll do our best to answer promptly, but in some cases it may take a day or two. If you bump your post, it may be removed. Bear with us and we'll get your question answered quickly.

Here are a few tips to help you to get your questions answered more rapidly.

IMPORTANT: Posts in English only. We don't employ translators and we'll be unable to understand your message properly and will probably delete it.
SOFTWARE: Each software has it's own forum. Software here is NOT supported. Posts about this software will be deleted. Supported software questions ONLY please.
SEARCH: Use the search option to see if your question has been answered on the forum before now or if there is an answer in the documentation of your software.
PERSONAL SUPPORT: If you have purchased a commercial version of any software, using the contact option at the licence centre ensures a faster response.
AUTO DELETION: Accounts older than 5 days, with no posts or topics, are automatically deleted. Only register if you are thinking of posting.
LINKS: Any links posted are not clickable (to deter spammers) and must be copied / pasted into your browser address bar.

            

You are not logged in.

Discus ProblemPosts in the Maian Weblog forum by magiccardpops
magiccardpops
20-05-2017 14:23:16

David -

When enabling Disqus it will display correctly but I get in "logs/errors.log" the error:

[Error Code: 8] Undefined index: discat
[Date/Time: 20 May 2017 @ 10:19AM]
[Error on line 46 in file /home/XXX/blog/control/classes/class.social.php]

Then, if I blank out the short name ( "You can totally disable Disqus again by removing the short name from the settings"  ) I will get the error:

[Error Code: 8] Undefined index: disqus
[Date/Time: 20 May 2017 @ 10:20AM]
[Error on line 27 in file /home/XXX/blog/control/classes/class.social.php]

although the Disqus app is no longer displayed.

magiccardpops
20-05-2017 18:14:13

Excellent, thank you David.

Klauwaart
11-09-2018 13:59:35

Well,I gave IntenseDebate a shot today and I must admit it worked first time and it worked flawlessly with Weblog.
Of course, stylistically, it was not what you would expect, probably because
a) Maian Weblog is not made to work with it and
b) I am not familiar with the ins and outs of the structures of the whole script.
Nevertheless, the comment box appeared immediately and worked perfectly.
Maybe an idea for quick implementation?
I don't think it would involve a lot of work.

Klauwaart
14-09-2018 09:30:27

Since I read here that adjusting disqus.htm seems to help, I would like to give it a try.
However, it is a bit unclear to me what exactly to fill in.
Shortname is obvious
CategoryID I set to "News" on Disqus, so i assume this is the one to put in disqus.htm
I guess url is shortname.disqus.com
But what about disqus_identifier, I haven't got a clue what to put there.

Also, in what format do you put the parameters down?

<div id="disqus_thread"></div>

         <script>
          //<![CDATA[
          var disqus_shortname   = '{short_name}';
          var disqus_identifier  = 'msw_journal_{id}';
          var disqus_url         = '{url}';
          var disqus_category_id = '{category}';

          (function() {
            var dsq   = document.createElement('script');
			      dsq.type  = 'text/javascript';
			      dsq.async = true;
            dsq.src   = '//' + disqus_shortname + '.disqus.com/embed.js';
            (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
           })();
           //]]>
         </script>

         <p><a href="http://disqus.com" class="dsq-brlink" rel="nofollow"><span class="logo-disqus">Disqus</span></a></p>

Do you leave everything as is and put the required information inside the curly brackets?
Thanks.

Klauwaart
18-09-2018 08:45:56

Wooo-hooooooo big_smile
It works, it works!!!!!!!

Thank you so much, David.
I can now officially open my blog.

Have a pint on me.

Klauwaart
18-09-2018 09:19:34

However, at the risk of going OT,
I noticed one very annoying thing:
(or maybe it is me doing something wrong)
When you enter a new topic in a journal, you always have to clear the fields in "Private" to make it public and you also have to constantly do the same whenever you edit any contet in the post or the content appears as private.
Is it me or can something be done about that?
Thanks.

100% Free SoftwareSoftware Versions, Development, Docs & UpgradesHostingNewsletter
Made with in the U.K & Hong Kong

Free PHP Software / Responsive PHP Scripts / Lightweight PHP Software / White Label PHP Software