Community Forum

Please read the intro before joining/posting. Thank you.

If you have questions about our software, chances are this forum has the answers.

You'll need to register before you can post on the forum to ask your question or to answer another one. A reply will be posted to each and every question that is asked so there is no need to double post or bump your post. We'll do our best to answer promptly, but in some cases it may take a day or two. If you bump your post, it may be removed. Bear with us and we'll get your question answered quickly.

Here are a few tips to help you to get your questions answered more rapidly.

IMPORTANT: Posts in English only. We don't employ translators and we'll be unable to understand your message properly and will probably delete it.
SOFTWARE: Each software has it's own forum. Software here is NOT supported. Posts about this software will be deleted. Supported software questions ONLY please.
SEARCH: Use the search option to see if your question has been answered on the forum before now or if there is an answer in the documentation of your software.
PERSONAL SUPPORT: If you have purchased a commercial version of any software, using the contact option at the licence centre ensures a faster response.
AUTO DELETION: Accounts older than 5 days, with no posts or topics, are automatically deleted. Only register if you are thinking of posting.
LINKS: Any links posted are not clickable (to deter spammers) and must be copied / pasted into your browser address bar.

            

You are not logged in.

Loading trackPosts in the Maian Music forum by Ariel
Ariel
25-09-2018 03:23:03

I am battling to load tracks, the root/secure folder shows no tracks after upload

ukdenny
09-07-2019 19:53:11

I am having the same issue. Tried allsorts of combinations in the settings to the secure folder but cannot add tracks. Getting quite frustrated after3 hours.

440Music
13-07-2019 08:05:04

have you checked the ownership and permissions on the directories?

Semper
14-07-2019 17:45:02

I can't figure out how to load a track period on here, and I think detailed instructions are needed.  The only option to load a track is via CSV file, and unless you know what that is, none of this makes sense.  Why can't you just upload an mp3 or mp4 file?  I'm not understanding this at all.  I just want to test this out before purchasing a license, but I can't do that without loading at least one track.  I see the demos and screenshots with preview links, so I know it can be done, but how?  The instructions are too vague.

Semper
14-07-2019 17:49:06

ukdenny wrote:
I am having the same issue. Tried allsorts of combinations in the settings to the secure folder but cannot add tracks. Getting quite frustrated after3 hours.


Me too.  All I want to do is load ONE track to see how it's done, and test the free version.  I'm ready to purchase a license, but i have to know that it works first.

Semper
15-07-2019 01:09:52

Hi David, thanks for the response.  I guess the part I'm lost on is how to create a CSV file, and why you need one just to upload a single track.  I love the design, and it appears to be just what I need, but I guess i just need to be step by step smart on it.  I have mp3 and mp4 files to use, and I've uploaded them to the folders required by the instructions, but the need for a CSV is kinda getting in the way.  What does it do, and why do you need it?  Also, when I do try to Import from CSV I get a popup telling me the free version only allows 100 tracks.  I haven't loaded any tracks yet, so why do i get that?

Semper
15-07-2019 03:35:36

Well I'm closer now, and it lets me select the folder, but it keeps saying there are no mp3 files in the folder even though I'm looking at them.  It even displays the correct path to them.  It's not recognizing my mp3 files no matter what folder I put them in.  I can change the path, but it never really gives me a folder selection.  Any folder it shows has (Root) next to it, and it says the folder is empty.

Semper
15-07-2019 13:15:55

I got it to work!  I must have had one little thing off in the path.  I just loaded two tracks.

alsmith
15-03-2021 11:21:09

I tried to add a track and immediatly have the error message
An error has occurred. For more details please view "logs/mm-error-log.log".

The log file shows
[Error Code: 8192] Function get_magic_quotes_runtime() is deprecated
[Date/Time: 15 March 2021 @ 06:48AM]
[Error on line 170 in file /home/north/public_html/cart/admin/control/classes/api/getid3/getid3.php]

this is the function in the php file
                // Check for magic_quotes_runtime
                if (function_exists('get_magic_quotes_runtime')) {
                        if (get_magic_quotes_runtime()) {
                                $this->startup_error .= 'magic_quotes_runtime must be disabled before running getID3(). Surround getid3 block by set_magic_quotes_runtime(0) and set_magic_quotes_runtime(1).'."\n";
                        }
                }

I found this https://github.com/JamesHeinrich/getID3/blob/master/getid3/getid3.php which supports PHP 7 per the changelog.
I replaced the file and no errors now.
Should I keep the replacement file?
Do you want to put this in a new release?

100% Free SoftwareSoftware Versions, Development, Docs & UpgradesHostingNewsletter
Made with in the U.K & Hong Kong

Free PHP Software / Responsive PHP Scripts / Lightweight PHP Software / White Label PHP Software